Home / Topic / Terminal error

Terminal error

Viewing 14 posts - 1 through 14 (of 14 total)
  • tradexcel12
    Participant
    #10408

    A couple versions back I began getting this error when I went to publish"The file “startCorona.command” could not be executed because you do not have appropriate access privileges."I checked, and my perms are fine - read/write for everyone. I can ignore it and it won't interfere with anything, and it only happens the first time I fire up the simulator for the day as long as I keep the terminal window open. Is this a bug or user error?

    Anonymous
    #15698

    Did you follow the original message to enable this?In the Finder, search for Terminal (not Corona Terminal) and start it. Then, copy the following line and paste it in the Terminal window:chmod a+x startCorona.command

    tradexcel12
    Participant
    #15699

    Thought I did but I'll copy and paste it again. Should I only have to do that once? When I try it now I get this error in the terminal windowchmod: startCorona.command: No such file or directoryThe simulator runs fine, files are being written as they should be, everything looks to be ok, even with these error messages.

    Anonymous
    #15700

    Sorry about that. After the chmod a+x you must enter the full path of startCorona.command (a simple way to do that is to drag the command file (available at /documents/Kwik) to the Terminal window.Or simply disable the option to not show messages in the Settings window (this way you'll get the full alert again).

    tradexcel12
    Participant
    #15701

    It still says it doesn't exist.Users-MacBook-351:~ User$ chmod a+x startCorona.command/Users/User/Documents/Kwik/startCorona.command chmod: startCorona.command/Users/User/Documents/Kwik/startCorona.command: No such file or directoryHow serious is this? I can turn the command on manually. But what happens if I merely ignore the error as I have been doing?

    Anonymous
    #15702

    there is an error in your name. the correct is:chmod a+x /Users/User/Documents/Kwik/startCorona.commandCan you please try again?

    tradexcel12
    Participant
    #15703

    Yup that worked. Thanks

    tradexcel12
    Participant
    #15704

    The coronacommand starts up very nicely now, but I am getting this error when the simulator launches for the first time – did not get it before the corona command was correctly doneCould not find the requested file "url=file:////Users/User/Documents/kwik/newfaf/build&skin=iPad%20Retina" This is NOT the path for my current project as it was setup in the project settings. The above path is an old project, not the one I'm currently working on.Of course I can point to the correct main.lua and the simulator pulls the right files, but I was wondering if this is something I need to be concerned about. Also I changed the kAudio file in my project folder, but it doesn't change on my pages. Is it looking at the above path instead of the correct one?I didn't run into any of these pathing issues with the other two projects I did. Wondering what silly thing I did to make this one different.

    Anonymous
    #15705

    Using the project with this weird error, check the coronaStart.command file contents and let me know if what you see there is something like this:open "corona://open?url=file:////Users/asouza/Documents/K2/test/build&skin=iPad Retina"this is the proper way it should be writing the command...

    tradexcel12
    Participant
    #15706

    The syntax is correct.The startcommand is in documents/kwik/ and the project file is newfafIt's contents are document/kwik/newfaf (and all the other stuff)BUT newfaf is located in desktop/faf-new/kwik/Did I mess myself up using kwik in the directory path?

    Anonymous
    #15707

    you probably changed your Default Project folder in the Settings window, no?In my sample open "corona://open?url=file:////Users/asouza/Documents/K2/test/build&skin=iPad Retina", my startCorona.command is on /Documents/Kwik (this is the path to ALL installations) but my project "test" is under my default project folder (set in the Settings window) at /Documents/K2/

    tradexcel12
    Participant
    #15708

    Sorry to be so dense this morning. OK my .kwk file for this project is in desktop/faf-new/kwik/newfafMy project folder has been set to ~/Desktop/faf-new/kwik/ since I began this project.I changed it to ~/Desktop/faf-new/kwik/newfaf - where the .kwk file is, and could no longer open the project.I want to submit this tomorrow, but am concerned I've done something wrong on the directory structure.

    Anonymous
    #15709
    tradexcel12
    Participant
    #15710

    I checked that thread and I don't appear to have the issues it addresses. My project correctly lives one level below the default folder that's in my settings so that's no problem. I copied everything over to where corona start command wanted to see it and the terminal complaints stopped and everything appears to be running as it should. I may have confused it by using Kwik in my directory tree on a path that wasn't document/kwik. From now on I'll just keep everything in the normal document/kwik path. Thanks Alex

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.

Privacy Preference Center

Strictly Necessary

these coolies are for WP-SpamShield, gdpr-wp, woocommerce, paypal

PHPSESSID, SJECT16, JCS_INENREF, JCS_INENTIM, gdpr, woocommerce_cart_hash, woocommerce_items_in_cart, woocommerce_recently_viewed, wordpress_, wordpress_logged_in_, wordpress_sec_, wordpress_test_cookie, wp_woocommerce_session_, AKDC, akavpau_ppsd

Functionality

WordPress cookie created when auto-saving a post in the editor.

wp-saving-post, wp-settings-, wp-settings-time-

Performance

google analytic

__utma,__utmb,__utmc,__utmz,_ga,_gid,_gat

Advertising