Home / Topic / Request for a new version

Request for a new version

Tagged: , ,

Viewing 15 posts - 1 through 15 (of 20 total)
  • #83401

    Hello

    After 5 books produced in these great product we have to mix code in lua for a small amusement with accelerometer.

    So there’s some point that seems to us as an improvement:

    – the CPU used when in kwik dialogs is huge. My fans start to shout out 🙂 Seems to be a way to get updates in photoshop but… I will live very well with an update button for that. Is that the cause?

    – the gtwen dialog could use the oriX and oriY mainly for x and y destination. Lot of my transitions dont move the X and Y. – also having a gtwen to related oriX and oriY could be a good way to reuse them – as an option…

    – seems to have a duplicated X on the gtwen.
    composer.gtween.new( layer.aa, 0.5, { x=layer.aa.x + ((773 + layer.aa.width/2) – layer.aa.x), y=layer.aa.y + ((1351 + layer.aa.height/2) – layer.aa.y), alpha=1, …
    seems to be the same as …
    composer.gtween.new( layer.aa, 0.5, { x= (773 + layer.aa.width/2), y= (1351 + layer.aa.height/2), alpha=1, …

    – having all actions and button functions inside an array could facilitate our reuse as well as reduce the problem of over 60 upvalues definition (http://forums.coronalabs.com/topic/17947-error-function-has-more-than-60-upvalues/?hl=+function%20+at%20+line%20+)

    Hope you consider ir positive
    Paulo Soares – Peopleware

    Yamamoto
    Keymaster
    #83402

    Thank you for the feedback. I will look into those issues in February

    Gareth
    Participant
    #83459

    Hi Naoya,
    would it be possible to get an update on your thoughts for Kwik this year? In September you mentioned that you will… “bring an entirely new Kwiksher experience, with Kwik version 4 coming back in the second quarter of 2015”

    Will our current project files be compatible with this new version?
    Could you outline possible release dates?

    I am working on two apps at present for release in the second quarter of 2015. I am wondering if the new version will require a full update from my project files.

    It would be great to get an update on your progress and plans.

    thank you,

    Gareth

    • This reply was modified 4 years, 5 months ago by  Gareth.
    Jorge
    Participant
    #83480

    I Nayoa,

    I do not know if this has already been mentioned before.
    Is it possible to change colors (RGB) of an object/image. In this way we could have several instances of the same object but with different colors. We have already it with different sizes and alpha. It could be done when we save an image as a shared asset and ideally also in the Edit Image control.
    Just to recall: is it also possible to have audio fade-out as we have fade-in?
    Many thanks.

    Jorge

    Yamamoto
    Keymaster
    #83494

    Reviewing my progress on Kwik4, I am thinking to release kwik3.5 for photoshop cc 2014 in May. This is full compatible with the current kwik3. User interface of kwik panel will be identical. Kwik3.5 does not require additional payment to use it.

    Kwik4 is now under development with a new internal architecture to handle lua template files and it will be released in June. Kwik4 won’t support kwik3 project files because the import function requires me more cost and time. Kwik4 extends a way of external codes/libraries to enhance app with custom codes. These custom codes are a kind of code snippets, for instance, audio fade out, change colors of object by object.fill() etc. The custom codes could override or extends the original kwik functions/objects. Much easier for me or developers to make such custom codes for enhancement requests. Kwik4 is orientated to become one of interface builders or level design tools for corona sdk. I will release first version of kwik4 minimum set of functions and update it to cover all kwik3 functions in iterative releases. So it is different license applied to kwik4, the price will be cheaper than kwik3.

    I will write an official blog about kwik3.5 and kwik4 next month.

    #83498

    Very interesting!
    We really expect for it.
    Could you give us some preview from the XML diferences between v3x and v4? Or an example… maybe we could prepare some XSLT to transform our projects started in 3 but who needs to go 4 asap.

    Jorge
    Participant
    #83499

    Hi Nayoa,

    Thanks for the update.Before we get your more extensive explanation in the blog, would you please be so kind and clarify the following:
    -Does Kwik 3.5 support PS CS6?
    -Will Kwik 4 ultimately replace Kwik 3.x?
    -Will Kwik 3.x continue to be supported?
    -How, we designers will migrate our v3x based projects into the new kwik generation? Do we need to re-create all the projects we have?
    -will we have a particles generator compatible with Corona Starter?

    Thanks in advance for you reply.
    Regards.

    Gareth
    Participant
    #83509

    Hi Nayoa,
    I think it is a great idea to release kwik3.5 for photoshop cc 2014 in May. This will leave us with a full version of Kwik that is compatible with the latest photoshop plugin system. We can then start new projects in Kwik4.
    thank you,
    Gareth

    Yamamoto
    Keymaster
    #83510

    -Does Kwik 3.5 support PS CS6?

    Yes. The inside codes for kwik3.5 are as same as the current 3.3.8. Kwik3.5 adds something to work with phothoshop cc 2014.

    -Will Kwik 4 ultimately replace Kwik 3.x?

    I don’t think so. I could port some good custom codes of kwik4 to kwik3 but possible new features of Kwik4 won’t be available in kwik3.x. Kwik4 is a kind of play ground or a challenging photoshop plugin because Adobe’s plugin platform has been renewed such as node.js server included, the possibilities are much bigger than kwik3.

    It could be better to introduce kwik4 as a new photoshop plugin. A new brother plugin of kwik3. Some cases like using widget table for a business app, it would be easier to use kwik4 or for new categories app like IOT to work with a sensor.

    -Will Kwik 3.x continue to be supported?

    Yes for those who like to continue good photoshop CS5.1, CS6 and CC.And of couse, for those like kwik3.5 on photoshop cc 2014

    -How, we designers will migrate our v3x based projects into the new kwik generation? Do we need to re-create all the projects we have?

    Yes. It is necessary to port a v3x project to kwik4. A use case I am thinking for kwik4 is that photoshop files of v3x and published lua files to be passed to a hand of good lua programmer and the programmer works with kwik4.

    -will we have a particles generator compatible with Corona Starter?

    It is good idea. I add it to the list of kwik4.

    • This reply was modified 4 years, 4 months ago by  Yamamoto.
    Jorge
    Participant
    #83513

    Thanks Nayoa for sparing some time to give these extensive explanations.
    These are excellent news. The fact that you call the new program Kwik 4 suggested me that the current version would one day disappear, which has worried me. It is now very clear and much better – we will have two powerful tools to choose.Very much appreciated.

    Concerning the particles generator, does it mean that Kaboom is now working with Corona Starter? If not, could you think of trying to get it? I must say that particles generator is something I strongly miss in Kwik, though the multiplier replacement sometimes helps.
    Thanks again and regards.

    susa38
    Participant
    #83514

    So if I understand, the people who do not like to get phtoshop cc can not get kwik 3.5 and kwik 4.
    I think is a little fustrating because we can start a project understanding that the project can have a very limited life.
    I say that because I suposse that in not a lot time kwik 3.x will have problems to upload to the stores, limited improves, and will be a tool that not incorpore the last possibilities to make something with the same atractive that other people.
    Is it correct? The people without photoshop cc can not use kwik 4?

    Yamamoto
    Keymaster
    #83515

    It is good point that users who likes photoshop cs5, cs6 and cc also would want kwik4.
    I will think about it later.

    we are dependent on Adobe platform. so kwik3.x won’t run now on CC2014.
    Kwik3.x is based on adobe CEP 4.x and extensions for CS6/CC host applications
    kwik4 uses CEP5 HTML/JavaScript extensions for CC2014 host applications.
    ref https://github.com/Adobe-CEP/CEP-Resources

    alexandres
    Participant
    #83602

    Yamamoto San (sorry to jumping in here and feel free to remove my posting if I am talking more than I should),

    DISCLAIMER FIRST: I don’t know what Kwiksher is planning for Kwik 4 so, everything that I am writing here is pure “user knowledge”!

    This is indeed great news! I am looking forward to learn about the things you are cooking with Kwik 4 – are you accepting beta testers already? 🙂

    Susa38, my understand is that Kwik 3.5 is the same Kwik 3.x, but now compatible with Photoshop CC 2014. If you haven’t plans to use CC 2014, no need to install Kwik 3.5 – the use of “3.5” is just to make people aware of the right version for CC 2014.

    As explained here and in other postings, Adobe decided to make CC 2014 platform not compatible with previous versions of Photoshop, making the life of developers miserable as it is very hard to re-write everything to a new platform.

    I like the way (just my opinion) Kwiksher is planning the future: if you are using an older version of Photoshop, keep using Kwik 3.x. For users willing to use CC 2014 AND a different development approach (explained above but, hopefully coming in more details with a blog posting), try Kwik 4, which will be a new product, potentially to a new audience.

    Yamamoto
    Keymaster
    #83604

    Thank you for your comment, Alex.

    The development of Kwik3.5 and Kwik4 are delaying. I am scheduling the private beta testing of kwil3.5 in the week of 20 April…

    yamamoto

    Fionnuala
    Participant
    #84289

    Hi Yamamoto

    Just wondering how are the plans coming for Kwik 4?

    Thanks

    Fionnuala

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.

Privacy Preference Center

Strictly Necessary

these coolies are for WP-SpamShield, gdpr-wp, woocommerce, paypal

PHPSESSID, SJECT16, JCS_INENREF, JCS_INENTIM, gdpr, woocommerce_cart_hash, woocommerce_items_in_cart, woocommerce_recently_viewed, wordpress_, wordpress_logged_in_, wordpress_sec_, wordpress_test_cookie, wp_woocommerce_session_, AKDC, akavpau_ppsd

Functionality

WordPress cookie created when auto-saving a post in the editor.

wp-saving-post, wp-settings-, wp-settings-time-

Performance

google analytic

__utma,__utmb,__utmc,__utmz,_ga,_gid,_gat

Advertising