Home / Topic / Problemas al crear menu bilingue

Problemas al crear menu bilingue

Home Kwiksher Forums Espacio Espanol Problemas al crear menu bilingue

Viewing 12 posts - 1 through 12 (of 12 total)
  • drhernand
    Participant
    #83881

    Buenas tardes, estoy creando un juego bilingue pero tengo problemas al crear el menu.

    Explico un poco mejor:

    cuando carga la aplicacion sale una pantalla donde se debe escoger el idioma ingles/espanol luego se ejecuta el juego en el idioma seleccionado. Hasta aqui todo bien.

    Dentro del juego coloque un boton con forma de engranaje que sera el Settings en donde al tocarlo debe aparecer el menu que cree, el cual contiene los botones para apagar la musica y si lo desean cambiar el lenguaje de ingles al espanol o viceversa.

    Este menu lo cree con capas en ingles y otras en espanol, cuando creo el grupo de capas y las coloco en Alpha 0 en kwiksher y lo monto el en simulador va de maravilla, al darle al boton se ejecuta la animacion lineal y me muestra el menu con todas las capas que cree, pero al indicar que capas pertenecen al espanol y cuales al ingles me genera una error en el simulador.

    Espero me puedan ayudar,

    Gracias.

    angel
    Participant
    #83883

    ¿Puedes poner un pantallazo del error?
    Hay una cosa que no entiendo bien de lo que describes:

    ¿Por qué pones las capas del menú en Alpha O?
    ¿El fallo se produce cuando tocas los botones de Ingles-español?
    ¿Has probado a poner Alpha 1? Entiendo que por Alpha te refieres a la transparencia de la capa. Si lo pones en O el botón lo inutilizas, en 1 sigue siendo transparente y funcional

    • This reply was modified 4 years, 4 months ago by  angel.
    drhernand
    Participant
    #83885

    Buenas noches Angel, el error me da despues de seleccionar el idioma en la pantalla anterior al de la aplicación Error

    drhernand
    Participant
    #83886

    Trate de crear un menu con scroll siguiendo este video https://www.youtube.com/watch?v=TyoOSYGLAkk y tambien me sale error y la coincidencia es que en ambos creo un grupo. Probe tanto sin asignarles idiomas a los layer como asignandolos y me da error igual.

    Anexo capturas de la configuración del grupo, scroll y del error.

    drhernand
    Participant
    #83887


    angel
    Participant
    #83890

    Si quieres mandame el proyecto por dropbox y te lo miro.

    drhernand
    Participant
    #83891

    Dale perfecto pero como se haría eso? trate de compartirlo por dropbox con mi hermano que esta en otro país pero al tratar de abrirlo no lo abre, sale en la lista de proyectos recientes pero las doble click y no abre.

    Saludos

    angel
    Participant
    #83892

    Comprime la carpeta del proyecto en ZIP o en RAR. Súbela a dropbox y dame el enlace de descarga

    drhernand
    Participant
    #83893
    angel
    Participant
    #83900

    He estado este fin d semana viendo tu proyecto detenidamente.

    Veo que tienes un lio bastante importante. Para empezar, lo mínimo es nombrar las capas y los botones y no usar máyusculas.

    Kwik necesita que le des todo muy “masticado” no se debe trabajar “on the fly”. Un buen storyboard antes de empezar es imprescindible para evitar muchos problemas, quebraderos de cabeza y perder mucho tiempo haciendo-deshaciendo-rehaciendo.

    Te digo esto por experiencia, me ocurrió cuando empecé hace ya un par de años.

    Mi consejo es que compres el curso en video “SVS TRAINING” en la tienda de Kwiksher. Es una maravilla. Te lo explican todo perfectamente. Empiezan desde cero y vas a prender a manejarlo a la perfección. Para mi fue un antes y un después.

    http://kwiksher.com/product/svs-training/

    Te he arreglado 2 fallos. Te dejo el link de dropbox con tu proyecto:

    https://www.dropbox.com/s/23boz1arzwbsen9/SciencePix.zip?dl=0

    Respecto al fallo de que no aparece el menú de settings mas que un fallo es un problema de configuración del multilenguaje. No le he metido mano porque habría que empezar prácticamente desde 0 y me llevaría mucho tiempo que no tengo 😉

    Para tu problema con el multi lenguaje, te pongo los links (no se si ya lo has visto) al tutorial en el que se explica con mucha claridad como hacerlo:

    http://kwiksher.com/tutorials_kwik/multi-part1/

    http://kwiksher.com/tutorials_kwik/multi-part2/

    http://kwiksher.com/tutorials_kwik/multi-part3/

    Espero que te sirva de ayuda.

    Un saludo!

    darias.jose
    Participant
    #83902

    Hola Angel, he visto que llevas mucho tiempo trabajando con kwiksher, y tendria una proposicion para tri , podrias escribirme a mi correo o darme el tuyo?:

    darias.jose@gmail.com

    angel
    Participant
    #83905

    Hola Jose, te pongo mi email: angelarcas”arroba”yahoo.es
    Me tienes intrigado con tu proposición! 😉

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Privacy Preference Center

Strictly Necessary

these coolies are for WP-SpamShield, gdpr-wp, woocommerce, paypal

PHPSESSID, SJECT16, JCS_INENREF, JCS_INENTIM, gdpr, woocommerce_cart_hash, woocommerce_items_in_cart, woocommerce_recently_viewed, wordpress_, wordpress_logged_in_, wordpress_sec_, wordpress_test_cookie, wp_woocommerce_session_, AKDC, akavpau_ppsd

Functionality

WordPress cookie created when auto-saving a post in the editor.

wp-saving-post, wp-settings-, wp-settings-time-

Performance

google analytic

__utma,__utmb,__utmc,__utmz,_ga,_gid,_gat

Advertising