Home / Topic / 64 bit Apple requirement

64 bit Apple requirement

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • psimedia@mac.com
    Participant
    #83246

    I know Corona has a roadmap to meet Apple’s 1 Feb 2015 64/32 bit universal requirement. Does Kwik need to make any adjustments? If so, is there a roadmap?

    JP

    Yamamoto
    Keymaster
    #83247

    I will make sure Kwik and Corona SDK 64bit daily build at the beginning of January. Reading Corona lab’s blog, it seems not much effect to Kwik. Just to rebuild with the updated Corona SDK.

    regards,
    yamamoto

    Odisej
    Participant
    #83442

    Hi, Yamamoto. Any news about this?

    Jorge
    Participant
    #83443

    Check it out. You have to read the article and there you will find a link for a beta build. I have downloaded and installed it, but have not yet submitted any app to the store.

    http://coronalabs.com/blog/2015/01/21/update-on-corona-ios-64-bit-support-and-plugins/

    Can anyone who gets in the front of it please share the experience?

    • This reply was modified 4 years, 5 months ago by  Jorge.
    #83578

    I wanted to check on the status of the above. I just submitted my app to Apple yesterday using Application Loader. App loader said all was well but then I found my app in iTunes Connect under the pre-release tabs saying “INVALID BINARY”

    The e-mail I received from Apple said the following: Dear developer,
    We have discovered one or more issues with your recent delivery for “Cocktails & Curiosities”

    To process your delivery, the following issues must be corrected:
    Missing 64-bit support – Beginning on February 1, 2015 new iOS apps submitted to the App Store must include 64-bit support and be built with the iOS 8 SDK. Beginning June 1, 2015 app updates will also need to follow the same requirements. To enable 64-bit in your project, we recommend using the default Xcode build setting of “Standard architectures” to build a single binary with both 32-bit and 64-bit code.

    I am using the latest version of Kwik and Corona V2014.2511

    #83579

    Update on my above note. I submitting the issue to Corona Forum as well and they responded with that link to the beta build
    http://coronalabs.com/blog/2015/01/21/update-on-corona-ios-64-bit-support-and-plugins/

    I downloaded the beta V2015.2545 and my submission was successful. Yeah!!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Privacy Preference Center

Strictly Necessary

these coolies are for WP-SpamShield, gdpr-wp, woocommerce, paypal

PHPSESSID, SJECT16, JCS_INENREF, JCS_INENTIM, gdpr, woocommerce_cart_hash, woocommerce_items_in_cart, woocommerce_recently_viewed, wordpress_, wordpress_logged_in_, wordpress_sec_, wordpress_test_cookie, wp_woocommerce_session_, AKDC, akavpau_ppsd

Functionality

WordPress cookie created when auto-saving a post in the editor.

wp-saving-post, wp-settings-, wp-settings-time-

Performance

google analytic

__utma,__utmb,__utmc,__utmz,_ga,_gid,_gat

Advertising