Home / Topic / Upload to app storePage 2

Upload to app store

Home Kwiksher Forums Help me! Upload to app store

Viewing 10 posts - 16 through 25 (of 25 total)
  • eric
    Participant
    #83195

    Ohh, the new version of corona fixes the CFstring issue! I am downloading it first thing tomorrow!

    Thanks, its a fun/cute game =)

    Jorge
    Participant
    #83196

    Wonderful. Congratulations!
    I will download a couple when we have our credit card re-validated.
    I thought the CFstring issue was resolved, in fact. However, I continue not to have the message “Your app is ready for distribution” when I build for ad hoc/store distribution. I am really struggling with it.

    eric
    Participant
    #83198

    Ok, when you try to build on Corona does it categorize your certs into Distribution and developer?

    Jorge
    Participant
    #83199

    Yes, indeed.
    I can see in Corona, when am going to build, all the profiles I have created either in the Dev Centre or in xCode. I have a distribution_ad hoc, distribution_app store and development for each one of the apps.
    Where do I stand now?

    -built an app with distribution_ad hoc
    -an app file with a message “Your application is ready to install on your device” was created
    -purposely ignored the message,created the Payload folder, zipped the app file and changed the name to .ipa
    -tried to upload the app using the Application Loader and voilá, a window pops up – “Deliver Your App” with the app identification items (e.g. name, SKU, version, App ID)
    -pressed Activity to see what happened and everything seems OK.
    -I have not pressed “Next” because I am not yet sure of the consequences (e.g. if I deliver it does it go to Review by Apple, or not yet bearing in mind that I have used the dist_ad hoc profile?)
    If I do so (and there is no review by Apple yet), will I be able to install the app on my device via the App Store?

    Please let me know if I am in the right path based on your experience. Thanks for the continued support.

    eric
    Participant
    #83200

    I would click next!
    You have to select it in iTunesconnect under the build section before it goes into review. if you got until the next step you are set for when you have your final build!

    Jorge
    Participant
    #83201

    Cool. I will read everything concerning testing, Flight Test and all concerned relevant information … and click Next. I will leave the result in this posting for others benefit.Thanks.

    Jorge
    Participant
    #83220

    Hi,
    We are now ready for testFlight.
    We have gone through the above process
    1-build with Corona -prov profile distribution_ad hoc
    2-message saying “ready to install on your device”
    3-move the generated file into a Payload folder
    4-zip the file and call it .ipa instead of .zip
    5-launch it using Application Loader
    6-everything seems alright, but suddenly a message pops up “ERROR ITMS 9000:”The IPA is invalid. It does not include a Payload directory”
    and when I get stuck.

    Furthermore, when Corona Simulator creates the file a message saying “Could not find image named “Icon”. Searching Corona´s forum it seemed to me that this message may be harmless but I do not know whether this is the case or not.

    I was never able to get the message “Your app is ready for distribution” after build with Corona Simulator. May be this the root cause and then I have to go back to the start. Why can I not see that message but instead “Ready to install on your device” regardless of the provisioning profile I use – Distribution-ad hoc, Distribution_app store.
    Please help. Thanks in advance.

    eric
    Participant
    #83254

    hmmm, those seem like Corona or Apple Code Signing issues. I would post on those forums.

    The IPA is invalid… I have gotten that error before, you said you zipped the file, you need to zip the whole Payload folder. That is my only idea, since it usually is a mistake on my part or I am moving too fast.

    But the other issues are not kiwk related, if corona is still not giving you the right message I would talk to them, they are very helpful.

    Jorge
    Participant
    #83256

    Thanks. I have found out that mistake – zipping the file instead of the folder!!
    I have in the meantime managed to load the apps to iTunes (Prerelease). It went through. However, I have not yet found out how to get the apps available for Internal Users (let alone External ones). When launching the app I get a n error message about not having the right beta test entitlement. This is strange since I have in the embedded provisioning profile a code line “beta-reports-active”, true”. I have also used AirSign to deal with it (I have seen this being recommended to resolve this specific issue), but no success.
    Finally, I never saw the message “Ready to Upload” -it is always ready to install on the device.But, again, it seems that it goes to the store!

    eric
    Participant
    #83264

    hmmm…. I have never done testing that way, I always just test on devices with a developer cert. Sorry, no help. 🙁

    May just be a funky bug or something if you aren’t getting that Ready to Upload message. I would ask Corona about it.

Viewing 10 posts - 16 through 25 (of 25 total)

You must be logged in to reply to this topic.

Privacy Preference Center

Strictly Necessary

these coolies are for WP-SpamShield, gdpr-wp, woocommerce, paypal

PHPSESSID, SJECT16, JCS_INENREF, JCS_INENTIM, gdpr, woocommerce_cart_hash, woocommerce_items_in_cart, woocommerce_recently_viewed, wordpress_, wordpress_logged_in_, wordpress_sec_, wordpress_test_cookie, wp_woocommerce_session_, AKDC, akavpau_ppsd

Functionality

WordPress cookie created when auto-saving a post in the editor.

wp-saving-post, wp-settings-, wp-settings-time-

Performance

google analytic

__utma,__utmb,__utmc,__utmz,_ga,_gid,_gat

Advertising