Home / Topic / Upload an app to appstore with old kwik and corona version

Upload an app to appstore with old kwik and corona version

Home Kwiksher Forums Kwik User Questions Upload an app to appstore with old kwik and corona version

Viewing 7 posts - 1 through 7 (of 7 total)
  • eyndrea

    Hello I use kwik and corona to make app for the appstore I made an app in december 2012 and other in march 2012In the first app I used kwik 2.1.1 and corona sdk 2012.894In the second app I used Kwik 2.2.4 and corona sdk 2012.894 Now I have to make some modifiications If I made the app with the new versions some errors appear.So i made them with the old versions and I test them in adhoc mode and all is ok. But when I try to upload to the appstore with application loader is say to me an error message " Your app contains non-public API usage. Please review the errors, correct them and resubmit your application""Apps are not permitted to access the UDID and must not use the uniqueldentifier method of UIDevice. Please update you apps and server to associate users with the Vendor or Advertising identifiers introduced in IOS 6""If you think this message was sent ierror and you have only Apple-published Apis in accordance with the guidelines, send the app's nine-digit Apple Id, along with detailed information..." Couldn't now make an app with older versions of kwik and corona? Is needed to modify my app to be compatible with the newest kwik and corona sdk to be able to upload to the appstore?


    You'll need to update Corona and Kwik, as Apple have changed lots of things since them. My suggestion to yo is to re-publish your entire project in Kwik and check in the simulator the errors generating. With that, to fix them will be much easier.


    I updated kik and corona.In this two projects i had before a group with some groups insideInside each group i had one layer and one buttonNow when export in kwik this page the log say to me that i have this errorIt say to me that the layer xxx is a button over state that can not be part of a groupRemove the layer from the groupI could in the app drag all the big group and after the user could press one button to go to other pageCan not have this now?Is not possible to drag something who include a button?Is there other way to do that?


    Did you remove from the group the over state layer Kwik alerted you to do so? Does the error still?


    I think you say i have to remove the button from the group.I can not remove only the over state. Can I? This field is not editableIf i remove the button from the group The error is out but when the user drag only drag the element inside the group.I had before one group named menubigInside this group there was 8 groupsInside each group there was 1 layer whith a square and a button(the button was one text)The menubig show only a part on the left of the screenThe user could drag the menu from left to right some pixels and then he could see the text and squares. Then he could press abutton to go to other pageFor this reason i had one group, inside 8groups with a square and text button (in the second app the text is multilingual)All worked fine but i can not upload to appstore with old version of corona and kwik so i have to updateIf you want You can see this app in appstore. The app name is pons quimicas. It is freeIn the section productos linea domestica you can see different linesFor example in detergentes para la ropa you can see the menubigWhen you go to one produc dragging the page to the left the menu with colors appear on the left.The user can go betwen product dragin the page but also can go to one line with the big menuIs it not possible now?


    What I meant was:- assuming you have a button from a layer named "abc" and you set the over state to layer "abc_over";- if you added both "abc" and "abc_over" layers into a group, Kwik will alert you that an over state layer (in this case "abc_over") cannot be used in the group - because over state layer do not exist in the code, besides a state in the button;In order to fix that, the only thing you need to do is to remove the "abc_over" layer from the group.Let me know if you understood what I meant and if it worked for you.


    Sorry but i have been testing a lot of things before.I have make the solution you say to me but does not work.Now I have sent to you two pages of the project to show  to you what I mean. I sent them to support@kwiksher.com I have a button from a group named abc. Inside abc group I have the layer named "kwklayer_x" and the layer named "barra_X". When I make the button for this group, in the over state I have the layer named "kwklay_x_over"This is an example. I have 8 groups like this. And all the 8 groups are inside a group with othe layer.This big group could be dragged by the user. But now I can not get it.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Privacy Preference Center

Strictly Necessary

these coolies are for WP-SpamShield, gdpr-wp, woocommerce, paypal

PHPSESSID, SJECT16, JCS_INENREF, JCS_INENTIM, gdpr, woocommerce_cart_hash, woocommerce_items_in_cart, woocommerce_recently_viewed, wordpress_, wordpress_logged_in_, wordpress_sec_, wordpress_test_cookie, wp_woocommerce_session_, AKDC, akavpau_ppsd


WordPress cookie created when auto-saving a post in the editor.

wp-saving-post, wp-settings-, wp-settings-time-


google analytic