Home / Topic / Kwik4 early previewPage 8

Kwik4 early preview

Home Kwiksher Forums Kwik4 Kwik4 early preview

Viewing 15 posts - 106 through 120 (of 135 total)
  • Gareth

    Yamamoto, I have emailed you the corona terminal error messages.
    What folder do I find the external .lua files?


    external lua files are published for page, it is components/pageXX/page_ext_lib_code.lua and for action, commands/pageXX/ext_xx.lua

    FIX:ultimatePosition for non ultimate project
    FIX:tmplt > component > page_ext_lib_code.lua

    I sent you email with particles lua files, Gareth.


    Thanks Yamamoto.
    I installed the new version and tested the particles on page 2 and 3, They work perfectly. I forgot to update the tmplt folder previously. When I updated it, it all worked in the Coronal Simulator.

    I will now go through my project to get all the other particles working. Then I’ll reorder the groups and finally test the page curl.

    Thanks again!


    I’m getting this error when click on the next page button in my book:

    ERROR: Runtime error
error loading module ‘components.page03.Text_sync_’ from file ‘/Users/BooMu/Documents/Kwik/Galaxy/build4/components/page03/Text_sync_.lua’:
 /Users/BooMu/Documents/Kwik/Galaxy/build4/components/page03/Text_sync_.lua:72: unexpected symbol near ‘,’
stack traceback:
 [C]: ?
 [C]: in function ‘require’
 ?: in function ‘require’
 /Users/BooMu/Documents/Kwik/Galaxy/build4/components/kwik/layerUI.lua:11: in function ‘setMod’
 /Users/BooMu/Documents/Kwik/Galaxy/build4/components/kwik/layerUI.lua:16: in function ‘_vars’
 /Users/BooMu/Documents/Kwik/Galaxy/build4/components/page03UI.lua:31: in function ‘setVars’
 /Users/BooMu/Documents/Kwik/Galaxy/build4/components/page03UI.lua:40: in function ‘create’
 /Users/BooMu/Documents/Kwik/Galaxy/build4/views/page03Scene.lua:15: in function </Users/BooMu/Documents/Kwik/Galaxy/build4/views/page03Scene.lua:13>
 ?: in function ‘dispatchEvent’
 ?: in function ‘gotoScene’
 /Users/BooMu/Documents/Kwik/Galaxy/build4/commands/kwik/pageAction.lua:40: in function ‘_listener’
 ?: in function <?:167>
 ?: in function <?:205>

    I tried to set up page curl which might be related to this error, but it’s not working. Does it show up in the corona simulator? How do I test page curl?


    Kayla, zip build4 folder and email it to support@kwiksher.com
    I will look into the error.

    How to enable PageCurl

    • photoshop, name background layer as ‘background’ in each page
    • kwik, disable preload next page
    • tmplt, rename components/pageXXX/page_swipe_curl.lua to page_swipe.lua or you copy the codes of page_swipe_curl.lua to page_swipe.lua. there is the backup of page_swip.lua as page_swipe_original.lua
    • page_swipe_curl.lua, curlWidth is defined at line 13 and line 18. For debug, line 110 you will find the debug codes which displays the grab regions, you may delete it.

    Hi Yamamoto,
    I am trying to install Kwik4_2016_1116 on my Mac. I have both Photoshop 2015 and 2017. I keep getting an error that says “Installation failed because the extension is not compatible with the installed applications”

    Kwik beta 4 works with PS 2015.



    Bob, are you using the latest ZXP Installer or ExManCmd?


    Installing Kwik4


    Hi Yamamoto,
    Updating to latest version of zxpinstaller did the trick. Sorry, I guess I should’ve checked that first.



    Could you maybe do a few video tutorials? I’m not able to get my page curl to work and I though a video might help. You don’t need to talk or anything.


    I’m also having an issue with auto play. If I click on read by myself, I can go back to the home page and choose another option. But if I click on auto play and go back to the home page, it continues to stay on auto play even if I click on read by myself. Is there a way to fix this?


    There was fix for auto play at 1125.

    Please download the following latest kwik and update tmplt from Project Properties > Update Template
    if this does not solve your issue, zip the build4 folder and sent it to me.

    FIX:Page Curl for ultimate config

    I made a simple tutorial with screen copies.

    Other new features – page curl

    • This reply was modified 7 years, 6 months ago by Yamamoto.

    Thank you for the tutorial. I was not using ultimate config and that was the problem. Auto play is still giving me problems even with the update so I will send you the build4 folder. I would also like to create a new project using ultimate config, but the “Project template: Browse” button is not clickable so I can not use my current project using new universal as a template to save time. The project template button has never worked for me.


    PageCurl works an universal project too. Open a kwik project and then Project Properties > Update template if you like to use a project made by Kwik3

    “Project template:Browse” in creating a new project is not related for page curl.


    Yeah I know that “Project template: Browse” is not related to page curl. I was just saying that that doesn’t work either.

    I can get page curl to work with a couple of pages but as soon as I add more pages or animation, page curl stops working. I also notice that if I “update template in project properties” like it asks me every time I open a project, it rewrites the changes I made to page_swipe.lua (page_swipe_curl.lua) in the pageXXX folder.

    Is anyone else experiencing this? Is anyone else having a hard time with page curl?


    I fixed the issues.

    FIX:New Project > Project Template is now “Copy Project”
    FIX:Tmplt update message appears even tmplt was latest
    New:export group layer option

    >I can get page curl to work with a couple of pages but as soon as I add more pages or animation, page curl stops

    Each background layer is named ‘background’?
    Adding animation to the other layers won’t affect the page curl.
    Does Corona simualtor oupt any error messages? If so, let me know.

Viewing 15 posts - 106 through 120 (of 135 total)

You must be logged in to reply to this topic.