Home / Topic / issues for updates (topic changed)

issues for updates (topic changed)

Home Kwiksher Forums Bug reporting (RETIRED) issues for updates (topic changed)

Viewing 11 posts - 1 through 11 (of 11 total)
  • gaugernpik
    Participant
    #9115

    Trying to finish up my first project with Kwik, and I'm afraid if there aren't significant improvements I won't be using it much more.I have a project with 11 files in it.  Each of those files has many layers in it - naturally.  With Kwik, if I have few layers things respond quickly and as I expect them to.  But if I get too many layers - and "too many" seems to be arbitrary, and not dependent on size of graphics; it also seems to be - but I could be mistaken - about the number of layers, and not the number of "actions" in a file - then Kwik inevitably, 100% of the time, gets sluggish.  Sometimes just really slow in responding to commands - more often than not just totally incapable of processing commands at all.  I'll tell a layer to do an interaction, but the interaction dialog won't open.  Or the dialog will open, but I'll get hung up inside the dialog box, unable to do anything there or close it.  Countless times in this project I've had to restart Photoshop with Force Quit, or even restart my computer to see if that clears any cobwebs.  Then I'll open the whole project again, and - again unpredictably - sometimes things I was trying to do a moment ago will now suddenly work again for awhile, until they don't.Other feedback:A scrollbar doesn't always appear in the dialog boxes for actions, for instance, if I've put in more than the window generally allows.Several times without thinking I've hit the big X next to the project section (where the little iPad icon is, and the progress bar when previewing) when I actually wanted to cancel the preview, not close the whole project.  There's some confusion presented in the UI here.I'd like to toggle audio on/off.  The mute sounds seems to be available only if there's background sound initiated.  But if I tell a button to play some audio, I'd like for that button to mute the audio on a second press.I identify from the UI that widgets are different from animations.  But if I want to initiate a "widget" in an action or in a button, I need to look for the animation icon, in order to load the widget I create.  Again, some UI issues there.In all incredibly impressive, especially considering it's coming from just one dude.  I'm hoping you can really dig under the hood in an upcoming update, even at the expense of adding more features for a round or two, and just really investigate stability and how to make Kwik much more rock solid than it is.  Thanks.

    Anonymous
    #11532

    Nitrox,Your feedback is very valuable. Thanks for that! Performance is something that I plan to improve in the next builds (you will read more about this topic in my next blog posting). You are right, Kwik is dependable of the number of layers, not actions or file sizes. The more layers you have, slower is all the process (it loops the number of layers all the time it needs to interact with them). Fact is, it is always a matter or requests and, in general, most users prefer to have more features to improve the final app than an update which brings mostly improvements. Saying that, if you cannot design your pages with less layers, you have to pay the performance prize at this moment.Regarding the other topics:- Although more layers mean more time opening window, it should not be an issue closing a window. If you are facing this, it is certain that you have a naming issue (or any other bug that I need to fix);- The scrollbar you mentioned is the panel one or the one in the button window?- You cannot stop the preview process. This is a javascript limitation in Photoshop. So, when started, you need to wait. Not the best thing in the world but it is the way it is. The CLOSE (x) project button shouldn't be an issue (in fact you are the first user complaining about it);- The mute/unmute acts for the entire volume, not for an especific audio (you need to manually edit your code if you want channel muting);- Widgets ARE pre-made animations (the code is the same, with the exception of switch images). If you plan to use widgets in buttons and actions, simply mark them as "Wait request" and they will appear in your animation list;

    gaugernpik
    Participant
    #11533

    Thanks for the reply – So, can nothing be done about the "performance price" beyond eliminating layers?  I figured it was a looping thing.  The project I'm working on presently just naturally has a lot of layers.  It's just killing me.  Lately I'm just crossing my fingers I'll be able to do what I need to do.The scrollbar issue is inside a dialog - for instance if I'm adding a touch interaction, but I want to do several things at once with that single touch interaction.  Sometimes the window showing me all the interactions I've added doesn't always scroll.The "preview" thing is just UI semantics, I think.  If I hover over the iPad icon, I see "preview".  Preview in software to me suggests something that isn't an actual render or publish but a preview of just that - when what you mean is, actually, publish.  I'm not confused about the functionality of the X button - but I had to learn it.  The UI is just unclear enough.  Even if I'm not the first person to complain about it, I doubt I'm the first person to experience it.  Simply changing that tooltip to "render" or "publish" or something other than "preview" would be more clear and meaningful.I understand what the mute button is for.  It's usually grayed out and unavailable, though, in my dialog boxes?  I'm suggesting a feature that let's me toggle audio on and mute it.  Are you saying that's outside the realm of future updates?Again, I understand what widgets are and how to use them - but the UI suggests something else, and I had to learn that.  The UI separates "animations" from "widgets".  Therefore if I'm setting up an action, I wanted to find a separate location for "animations" than I did "widgets".  I had to learn by looking around that oh - my widget is now inside of animations.  It presents confusion that there's a butterfly icon for one thing, and a recycle button for another thing, but then elsewhere when i want to reference something from the recycle icon I need to actually initiate it from the butterfly icon.  See what I'm saying?  Maybe a few words in the user doc would help, or ideally you move widgets as some kind of sub-entity inside of animations, if that's where I should expect to find them when working elsewhere in the app (or, when initiating events, I have an option to call up my widgets properly, and not as "animations".)  All in the spirit of improvement.  Again, I'm overall very impressed you came up with all this.PS - text input via Kwiksher would be huge.  I have need for a box where users can type stuff in themselves, and bet others would find that fun.  Probably bridging closely now to a GUI for Corona proper, but thought I'd mention it.

    Anonymous
    #11534

    Keep sending your findings! The Mute button is a special one (that's why you cannot mix it with other actions). this is the fact the way Corona handles a toggle button (they are not equal to other buttons). Mute (in fact it should be more a dispose audio, to avoid memory issues) particular sounds is something that I plan to add, but not anytime soon. This is because it would require another interface change and the complexity of track where (which channel) the audio is playing. Currently Kwik sets the channel while previewing/publishing.I agree with your point on adding the Widgets as animations. I will probably do that in version 2, when I will review the interface.Text input is something that I am planning to bring (probably version 1.9 or 2). About performance, let see what the next survey shows (maybe you are not alone here). Thanks for the patience and support!

    v1p_kokorin
    Participant
    #11535

    I have officially entered into the “slow performance” zone. My project has a LOT of layers, and I have opted by duplicating the XML code by copying and pasting… I am using actions, which don't require me to watch for “automatically” generated variable names. The problem comes up when I need to “show” a layer. Since these show_### tags are automatically generated, I cannot just copy and paste and change the variable/layer names.Alex, what is the best way to work around this issue? How does Kwik choose what 3-digit number give to the "show_###" tag? Is there a way to add more manually? I can duplicate all the button actions and change the layer names, but then I have to go back and add the show part of the action...which makes me wait up to 2-3 minutes for the window to pop up...Could you suggest a better way to do this? Also, has this been improved in K2?Thanks;

    Code:

    v1p_kokorin
    Participant
    #11536

    Ps: I am super excited for K2 to come out tomorrow 🙂

    Anonymous
    #11537

    actions ids can have any name (besides layer names). the names generated are random ones.

    v1p_kokorin
    Participant
    #11538

    Thanks Alex.I'll give that a try.Good luck with the launch!

    v1p_kokorin
    Participant
    #11539

    Sorry to bother you again Alex. This is about my XML code duplication. So I understand that Actions can be named whatever we want, but that doesn't seem to be the case with “Show/Hide” actions. Let me explain. I took this code and duplicated it:          action_792          hide_letter_menu          Play ActionThis worked like a charm, mainly because it was just pointing to the same "trigger" and didn't depend on layer names. Inside the trigger, I have a "show_###" event. Now, I created a Show/Hide event (button) in Kwik (which we cannot rename, or name). And all I wanted was to be able to copy that code, change the name of the "show_###" tag, and save myself 1 hours of waiting. Trust me, this little trick saved me a LOT of time!! Everything worked, except the Show/Hide button event. Which I named "show_Bbig". This name (usually randomized by kwik), I believe is the reason why it didn't work. So I thought, ok, maybe it's because I used a string name, instead of a 3-digit integer...but, what if I use a number that has already been randomly assigned to a show_### event?          show_964          Bbig          true          false          0          0          Show/HideMy questions to you are:- Will Kwik assign a new number if it detects that the number is already assigned in a Show/Hide event? What if there are more than 999 Show/Hide events? will Kwik continue to randomly select from 4-digit numbers?- Given that Kwik currently does not allow renaming a Show/Hide event, is it possible to manually name them differently?- Why is are the 3-digits assigned randomly? Why not sequentially? I think it would help us if we wanted to add Show/Hide events manually without running onto duplicates.Other than this hiccup, I was able to duplicate those buttons and execute all the actions that I created (but not the Show/Hide events, just actions). Now, I could create an action of a Show/Hide event, but that would defeat the purpose of the shortcut, since for the Show/Hide dialog to appear, I have to wait the same amount of time (30-60 seconds) for the dialog to appear. I hope you are able to give me some insights.Thanks.

    v1p_kokorin
    Participant
    #11540

    Wait a minute….now that I finally get to compile my whole project with Kwik 2, I'm getting errors with all my actions…even for pages I haven't edited in weeks. I am having to re-select the action I had already specified because there's nothing in the “data” portion of the window…I'm getting this error:A non-existent action (Play Action) "" was called from button "B_selection" in page "letters_book". -> EDIT THE BUTTON OR DELETE IT; A non-existent action (Play Action) "" was called from button "B_selection" in page "letters_book". -> EDIT THE BUTTON OR DELETE IT; A non-existent action (Play Action) "" was called from button "B_selection" in page "letters_book". -> EDIT THE BUTTON OR DELETE IT; A non-existent action (Play Action) "" was called from button "B_selection" in page "letters_book". -> EDIT THE BUTTON OR DELETE IT; A non-existent action (Play Action) "" was called from button "B_selection" in page "letters_book". -> EDIT THE BUTTON OR DELETE IT; I go to the button menu and all the actions are there, except there is no "Data" description, but the ID's are there. I can re-select them, and for pages with very little layers, I have no problem re-selecting them...but doing that for 40+ layers...taking an average of 1 minute per layer, adds up. I never had problems with this in K1... Is anyone else having problems migrating projects with actions? I noticed the "trigger" tag is gone... Did kwik 2 alter current actions in any way? I'd like to hear from other migrating users.https://www.dropbox.com/s/602kwwepcw3omty/Add%20Button1.pnghttps://www.dropbox.com/s/aptlzvs5dbtb79x/Add%20Button1-2.pngThanks;

    Anonymous
    #11541

    the actions must have names. it seems this is the issue with the debug system…

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Privacy Preference Center

Strictly Necessary

these coolies are for WP-SpamShield, gdpr-wp, woocommerce, paypal

PHPSESSID, SJECT16, JCS_INENREF, JCS_INENTIM, gdpr, woocommerce_cart_hash, woocommerce_items_in_cart, woocommerce_recently_viewed, wordpress_, wordpress_logged_in_, wordpress_sec_, wordpress_test_cookie, wp_woocommerce_session_, AKDC, akavpau_ppsd

Functionality

WordPress cookie created when auto-saving a post in the editor.

wp-saving-post, wp-settings-, wp-settings-time-

Performance

google analytic

__utma,__utmb,__utmc,__utmz,_ga,_gid,_gat

Advertising